Como Saver que Dependencias Necesita un Programa antes de Instalarse en Debian Lenny

Cuando instalamos paquetes en ocasiones puede marcar que puede instalar por falta de dependencias necesarias para el paquete. Que podremos hacer en estos casos tenendremos que investigar cuales son las dependencias e instalarlas pero seria buscar dependencia por dependencia en cual puede ser algo tedioso.

Lo bueno que tenemos las distribuciones debian y derivados que tienen una herramienta que nos ayudara a
buscar las dependencias necesarias para nuestra aplicaciones antes de instalar, esta herramienta se conoce como apt-rdepends.

También nos muestra las dependencias de la dependencia de un paquete.

Para poder tener esta herramienta en nuestra distribuciones solamente tendremos que instalar de la siguiente manera:

parkito:~# apt-get install apt-rdepends

Terminada la instalacion, su nomenclatura del comando apt-rdepends es muy sencilla de utilizar solamente tendremos que indicar el paquete que deseamos instalar.

parkito:~# apt-rdepends xmms
Leyendo lista de paquetes… Hecho
Creando árbol de dependencias
Leyendo la información de estado… Hecho
xmms
Depende: libasound2 (>> 1.0.16)
Depende: libaudiofile0 (>= 0.2.3-4)
Depende: libc6 (>= 2.7-1)
Depende: libesd-alsa0 (>= 0.2.35)
Depende: libesd0 (>= 0.2.35)
Depende: libgl1
Depende: libgl1-mesa-glx
Depende: libglib1.2ldbl (>= 1.2.10-18)
Depende: libgtk1.2 (>= 1.2.10-4)
Depende: libice6 (>= 1:1.0.0)
Depende: libmikmod2 (>= 3.1.10)
Depende: libogg0 (>= 1.0rc3)
Depende: libsm6
Depende: libvorbis0a (>= 1.1.2)
Depende: libvorbisfile3 (>= 1.1.2)
Depende: libx11-6
Depende: libxext6
Depende: libxi6
Depende: libxxf86vm1
Depende: zlib1g (>= 1:1.1.4)
libasound2
Depende: libc6 (>= 2.7-1)
libc6
Depende: libgcc1
libgcc1
Depende: gcc-4.3-base (= 4.3.2-1.1)
Depende: libc6 (>= 2.7-1)
gcc-4.3-base
libaudiofile0
Depende: libc6 (>= 2.5-5)
libesd-alsa0
Depende: esound-common (>= 0.2.36-3)
Depende: libasound2 (>> 1.0.10)
Depende: libaudiofile0 (>= 0.2.3-4)
Depende: libc6 (>= 2.3.5-1)
esound-common
libesd0
Depende: esound-common (>= 0.2.36-3)
Depende: libaudiofile0 (>= 0.2.3-4)
Depende: libc6 (>= 2.3.5-1)
libgl1
libgl1-mesa-glx
Depende: libc6 (>= 2.7-1)
Depende: libdrm2 (>= 2.3.1)
Depende: libx11-6
Depende: libxdamage1 (>= 1:1.1)
Depende: libxext6
Depende: libxfixes3 (>= 1:4.0.1)
Depende: libxxf86vm1
libdrm2
Depende: libc6 (>= 2.7-1)
libx11-6
Depende: libc6 (>= 2.7-1)
Depende: libx11-data
Depende: libxcb-xlib0
Depende: libxcb1
libx11-data
libxcb-xlib0
Depende: libc6 (>= 2.7-1)
Depende: libxcb1
libxcb1
Depende: libc6 (>= 2.7-1)
Depende: libxau6
Depende: libxdmcp6
libxau6
Depende: libc6 (>= 2.7-1)
libxdmcp6
Depende: libc6 (>= 2.7-1)
libxdamage1
Depende: libc6 (>= 2.7-1)
Depende: libx11-6
Depende: libxfixes3 (>= 1:4.0.1)
libxfixes3
Depende: libc6 (>= 2.3.6-6)
Depende: libx11-6
PreDepende: x11-common (>= 1:7.0.0)
x11-common
Depende: debconf (>= 0.5)
Depende: debconf-2.0
Depende: debianutils (>= 1.13)
Depende: lsb-base (>= 1.3-9ubuntu2)
PreDepende: debconf
PreDepende: debconf-2.0
debconf
Depende: debconf-english
Depende: debconf-i18n
PreDepende: perl-base (>= 5.6.1-4)
debconf-english
Depende: debconf
debconf-i18n
Depende: debconf
Depende: liblocale-gettext-perl
Depende: libtext-charwidth-perl
Depende: libtext-iconv-perl
Depende: libtext-wrapi18n-perl
liblocale-gettext-perl
Depende: libc6 (>= 2.7-1)
PreDepende: perl-base (>= 5.10.0-9)
PreDepende: perlapi-5.10.0
perl-base
PreDepende: dpkg (>= 1.14.20)
PreDepende: libc6 (>= 2.7-1)
dpkg
PreDepende: coreutils (>= 5.93-1)
PreDepende: libc6 (>= 2.7-1)
PreDepende: lzma
coreutils
PreDepende: libacl1 (>= 2.2.11-1)
PreDepende: libc6 (>= 2.6.1-1)
PreDepende: libselinux1 (>= 2.0.15)
libacl1
Depende: libattr1 (>= 2.4.41-1)
Depende: libc6 (>= 2.7-1)
libattr1
Depende: libc6 (>= 2.7-1)
libselinux1
Depende: libc6 (>= 2.7-1)
lzma
Depende: libc6 (>= 2.7-1)
Depende: libgcc1 (>= 1:4.1.1)
Depende: libstdc++6 (>= 4.2.1)
libstdc++6
Depende: gcc-4.3-base (= 4.3.2-1.1)
Depende: libc6 (>= 2.7-1)
Depende: libgcc1 (>= 1:4.1.1)
perlapi-5.10.0
libtext-charwidth-perl
Depende: libc6 (>= 2.7-1)
Depende: perl-base (>= 5.10.0-9)
Depende: perlapi-5.10.0
libtext-iconv-perl
Depende: libc6 (>= 2.7-1)
Depende: perl-base (>= 5.10.0-9)
Depende: perlapi-5.10.0
libtext-wrapi18n-perl
Depende: libtext-charwidth-perl
debconf-2.0
debianutils
PreDepende: libc6 (>= 2.7-1)
lsb-base
Depende: ncurses-bin
Depende: sed
ncurses-bin
PreDepende: libc6 (>= 2.7-1)
PreDepende: libncurses5 (>= 5.6+20071006-3)
libncurses5
Depende: libc6 (>= 2.7-1)
sed
PreDepende: libc6 (>= 2.7-1)
libxext6
Depende: libc6 (>= 2.7-1)
Depende: libx11-6
Depende: libxau6
Depende: x11-common
libxxf86vm1
Depende: libc6 (>= 2.7-1)
Depende: libx11-6
Depende: libxext6
libglib1.2ldbl
Depende: libc6 (>= 2.5-5)
libgtk1.2
Depende: libc6 (>= 2.6-1)
Depende: libglib1.2ldbl (>= 1.2.10-18)
Depende: libgtk1.2-common (>= 1.2.10-18.1)
Depende: libx11-6
Depende: libxext6
Depende: libxi6
PreDepende: dpkg (>= 1.6.8)
libgtk1.2-common
libxi6
Depende: libc6 (>= 2.7-1)
Depende: libx11-6
Depende: libxext6
Depende: x11-common
libice6
Depende: libc6 (>= 2.6-1)
Depende: x11-common
libmikmod2
Depende: libc6 (>= 2.3.2.ds1-4)
libogg0
Depende: libc6 (>= 2.7-1)
libsm6
Depende: libc6 (>= 2.7-1)
Depende: libice6 (>= 1:1.0.0)
Depende: x11-common
libvorbis0a
Depende: libc6 (>= 2.7-1)
Depende: libogg0 (>= 1.1.0)
libvorbisfile3
Depende: libc6 (>= 2.7-1)
Depende: libvorbis0a (>= 1.2.0)
zlib1g
Depende: libc6 (>= 2.7-1)
parkito:~#

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s